- 01 Jul 2025
- 1 Minute To Read
-
Print
-
DarkLight
-
PDF
Content does not appear on my application
- Updated On 01 Jul 2025
- 1 Minute To Read
-
Print
-
DarkLight
-
PDF
Issue
Whatfix Content doesn’t load on an application even when you have configured the visibility and display rules correctly.
Probable Cause
Sometimes, if the URL of the application where you want to view the content is not added as a condition in the Whatfix Guidance Dashboard, Whatfix Content doesn’t appear.
Content delay due to extension-based deployment. The browser extension synchronizes with the Whatfix CDN at regular intervals, which may delay visibility by up to 30 minutes.
Suggested Solution
Ensure you add the instances where you want Whatfix Content to appear in Content deployment section under Settings. For more information, see How to add conditions in Map Stages?.
If you use an extension-based deployment, you may have to wait up to 30 minutes before the content appears for your end users. This delay occurs because the browser extension synchronizes with the Whatfix CDN at regular intervals. To ensure content immediately appears on your application, use a Whatfix Store deployment. For more information, see Whatfix Store: Our recommended choice to host Whatfix extensions.
aadddddddddddddddddddddddd