- 30 Oct 2024
- 1 Minute To Read
-
Print
-
DarkLight
-
PDF
Pop-up continues to appear even after occurrence is exhausted
- Updated On 30 Oct 2024
- 1 Minute To Read
-
Print
-
DarkLight
-
PDF
Issue
You set an occurrence for a Pop-up, but it keeps reappearing for some users, even after they've viewed the Pop-up for the assigned number of times.
Probable Causes
- The Use of the Skip button on your Pop-up.
- An issue with cache data in your browser or the local storage may not be working properly on your device. This can cause issues with user detection and the reappearance of Whatfix Widgets like Pop-ups and more.
Suggested Solutions
Use any of the following methods to solve the issue:
-
When your end users click the Skip button, it is not considered an interaction, and the Pop-up continues to display to your users on their next visit or on page refresh. This behavior is not impacted by the occurrences you have set in the Pop-up settings. Users who click the Skip button continue to see the Pop-up until they click the Close button or X icon.
For example, consider that you created a Pop-up with only a Skip button and no Close button or X icon. If you set the display count of the Pop-up to 1 and a user clicks the Skip button, they will continue to see the Pop-up until they close the Pop-up manually using the Close or X icon. Whatfix recommends that you always have either a Close button or enable the X icon to avoid this scenario.
-
Perform a hard refresh on the browser.
-
Contact your IT Administrator to find out whether there is an issue with the local storage or user detection capabilities of your device.
If the issue persists, contact support@whatfix.com.