- 10 Sep 2025
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Chatbot fails to load inside Self Help
- Updated On 10 Sep 2025
- 1 Minute To Read
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Issue
When you try to integrate Chatbot in Self Help, you see the following error: mpgmea.service-now.com refused to connect.
Probable Causes
The Chatbot does not embed inside Self Help in the following scenarios:
Your application has the following header enabled:
X-Frame-Options: sameorigin
in the application code. With this header, the Chatbot only appears when opened directly on the same domain, not when embedded within Whatfix.Note:
If you do not have access to the application code, contact your IT team.
A Content Security Policy (CSP) restricts embedding the Chatbot.
Suggested Solutions
Contact your IT team and request them to allow the Whatfix domain to embed the Chatbot. Do the following changes to resolve the issue:
Remove or adjust the
X-Frame-Options
header in the application code.Modify the CSP to include Whatfix in the frame-ancestors list:
Content-Security-Policy: frame-ancestors 'self' https://*.whatfix.com
. For a full list of domains to whitelist, see What are the trusted Whatfix domains to whitelist?
Note:
If the issue persists, contact support@whatfix.com.