Translated content not showing to users
- 20 Aug 2025
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Translated content not showing to users
- Updated On 20 Aug 2025
- 1 Minute To Read
- Print
- DarkLight
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Issue
Translated Whatfix Content is not showing to end users.
Probable Causes
- Whatfix is unable to detect the language of the application.
- The content is not translated.
- The display rules used to identify pages of the application varies based on the URL. For example, if you want to display content in Portuguese, one part of the site might use
pt
while another usespt-pt
as the language code. - Window variables used to determine location might prevent the widget (for example, a Self-Help or Task List) from appearing on your application. For example,
_wfx_location
might be set touk
, and displays translated content to only users in the United Kingdom.
Suggested Solutions
- Check if the language code is added in the Advanced Configuration code snippet. This enables Whatfix to detect the current language that the user is using on the application and then show content in that language. To add the language code in Advanced Customization, see Enable Whatfix to detect the language of your application.
- Ensure that all content is translated. For more information, see Translate Whatfix Content.
- Include all pages where you want to display translated content on the application page as a display condition. For example, URL contains
pt
andpt-pt
. - In the widget Visibility Rules, check if the additional conditions, such as a window variable or cookie value, restrict content to specific users. Edit the values accordingly.
Note:
If the issue persists, contact support@whatfix.com.
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