Why can't I auto-translate multiple content?
- 27 May 2024
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Why can't I auto-translate multiple content?
- Updated On 27 May 2024
- 1 Minute To Read
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Issue
When you try to auto-translate multiple pieces of Whatfix content or select fields within Whatfix content on the Translation page, the translation fails and appears with an Out of sync badge and the Input translations fields appear empty.
Cause
Whatfix uses Microsoft Translator to auto-translate content via API calls. As a result, Microsoft allows translation of Whatfix content only if the Primary language in Translations page is set to English (en).
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- if the primary language is set to other versions of English, such as English - US (en-US) or English - UK (en-UK), Microsoft does not allow auto-translation.
Solution
Change the primary language in the Translations page to English (en).
For more information, see Change the primary language for auto-translating content.
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