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Why can't I auto-translate multiple content?
  • 13 Feb 2025
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Why can't I auto-translate multiple content?

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Article summary

Issue

Auto-translating multiple pieces of Whatfix content or selecting fields within Whatfix content on the Translations page results in a translation failure. The translation fails and appears with an Out of sync badge and the Input translations fields appear empty.

Probable Cause

Whatfix uses Microsoft Translator to auto-translate content via API calls. As a result, Microsoft allows translation of Whatfix content only if the Primary language in Translations page is set to English (en).

Note
  • if the primary language is set to other versions of English, such as English - US (en-US) or English - UK (en-UK), Microsoft does not allow auto-translation.

Suggested Solution

Change the primary language in the Translations page to English (en).
translations_primary_lang_en

For more information, see Change the primary language for auto-translating content.


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