- 17 Dec 2021
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Content not showing up in Self Help
- Updated On 17 Dec 2021
- 1 Minute To Read
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Causes:
The Content such as Flows, Videos, Text, etc. may not show up in Self Help when the content:
- is not a part of any segment
- does not have proper tags attached to it
- is segmented to not appear to certain users based on their roles
Solutions:
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Ensure that the content is a part of any segment. Content is displayed in Self Help only if it is part of the Self Help segment.
For more information on adding content to a segment, see What is Segmentation? -
If you are using a role tag, make sure that all your content has at least one role tag.
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Check whether user roles are used to segment content. If so, make sure the contents are added to the specific Self Help segment.
See Displaying content based on user roles -
Check if the content is appropriately tagged. The Self Help segment may have been created using a selected tag method, and the Content that is not appearing may not have the associated tag. For example, a production tag.
Check for the following criteria if you have Smart Context enabled account.
- For static content such as Videos, Links, and Texts, each content must have the respective page tag for it to display in Self Help on a particular page. Any content that is not tagged does not appear.
- If the content needs to be part of Self Help across all segments, make sure you are using a global tag.
- For Dynamic content such as Flows, if the content is not appearing in Self Help, check if there is a role or page tag to be added, and sign in as that user to check. If the tags are properly applied, and still the content is not showing up, then contact [email protected].
- When Smart Context is enabled, then the location in which content is displayed is determined by where the content was created. For example, a Flow about Widgets will not appear in the Self Help when opened on the Content page.