PDF content does not show in QuickRead
- 10 Mar 2025
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PDF content does not show in QuickRead
- Updated On 10 Mar 2025
- 1 Minute To Read
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Print
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PDF
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Issue
When you search in Self Help, you encounter one of the following scenarios:
- QuickRead does not generate a response, even though the PDF contains relevant content.
- QuickRead generates a response, but a relevant PDF is not part of the response's Sources.
In both cases, QuickRead either shows no response or provides a response that excludes content from the relevant PDF.
Probable Causes
- QuickRead is disabled when you upload the PDF.
- QuickRead has not processed your PDFs yet.
- PDF visibility is restricted by Role tags.
- The PDF is part of a repository that requires authentication.
- The PDF exceeds 4MB in size.
Suggested Solutions
- QuickRead processes PDFs only if you enable it before uploading the PDFs. If QuickRead is disabled at the time of upload, enabling it later does not process existing PDFs. In this case, you must re-upload the PDFs after enabling QuickRead.
To enable QuickRead, see How to Enable QuickRead?
Note:
After enabling QuickRead, use Preview mode in Studio to test it on Self Help. You must do a push to Production for these changes to reflect for your end users.
- Information from PDFs is filtered from QuickRead's responses if you do not satisfy the Role tag requirements to view the PDF. For more information, see Add Page tags and Role tags to your content.
- Add the PDF in a repository that does not require authentication, or upload Whatfix content.
- For QuickRead to generate responses based on a PDF content type, the PDF's size must be less than or equal to 4MB.
Note:
If the issue persists, contact support@whatfix.com.
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