---
title: "Unable to see new content after updating the extension"
slug: "unable-to-see-new-content-after-updating-the-extension"
updated: 2026-02-06T11:40:40Z
published: 2026-02-06T11:40:40Z
canonical: "support.whatfix.com/unable-to-see-new-content-after-updating-the-extension"
---

> ## Documentation Index
> Fetch the complete documentation index at: https://support.whatfix.com/llms.txt
> Use this file to discover all available pages before exploring further.

# Unable to see new content after updating the extension

## Issue

Unable to see the newly published content after updating the extension.

## Probable Cause

When you **Publish** content from the Dashboard, it automatically updates the extension and pushes the newly created content to the server based on your deployment method (Whatfix Cloud, Self Hosted or On Premise). The successful email you receive confirms that this process has completed. However, the content may take a little longer before it can be seen on your end user's extension. For more information, see [How long does it take for Whatfix content to go live?](/studio/docs/how-long-after-a-push-to-production-does-it-take-for-whatfix-content-to-display-for-end-users)

## Suggested Solutions

Check the updated extension's version number on the Whatfix dashboard and the extension page of your browser. If they are different, try updating the extension again and wait for the extension versions to be in sync.

Use the following steps to find the extension version number:

On the Whatfix dashboard

1. On the Whatfix Guidance dashboard, click **Settings**. ![ia_left_nav_settings](https://cdn.document360.io/a268766e-d74d-4619-9613-e2472f809ffb/Images/Documentation/ia_left_nav_settings.png)
2. Click **Content deployment**. ![ia_settings_content%20deployement](https://cdn.document360.io/a268766e-d74d-4619-9613-e2472f809ffb/Images/Documentation/ia_settings_content%20deployement.png)

1. Go to the extension card you have updated, and then click **Details**. ![details_chromium](https://cdn.document360.io/a268766e-d74d-4619-9613-e2472f809ffb/Images/Documentation/details_chromium.png)
2. Check the **VERSION** number for the extension you have selected and updated. ![details_version](https://cdn.document360.io/a268766e-d74d-4619-9613-e2472f809ffb/Images/Documentation/details_version.png)

Note:

The Extensions tab does not display the latest **version** of the .ZIP file.

On the Chrome browser

1. Open your Chrome browser and Go to the **Extensions** page.  

![chrome_extensions_page](https://cdn.document360.io/a268766e-d74d-4619-9613-e2472f809ffb/Images/Documentation/chrome_extensions_page.png)
2. Go to the extension card and check the version number at the top.  

![clm_browser update](https://cdn.document360.io/a268766e-d74d-4619-9613-e2472f809ffb/Images/Documentation/clm_browser%20update.png)

Note:

If the issue persists, contact [support@whatfix.com](mailto:support@whatfix.com?Subject=Unable%20to%20see%20new%20content%20after%20updating%20the%20extension&amp;Body=Hello%20Team%2C%0A%0AI%27m%20unable%20to%20see%20new%20content%20after%20updating%20the%20extension.%20Kindly%20provide%20assistance.%0A%0AMore%20information%3A%20%0A%0AThanks%20and%20regards.).

## Related

- [Choose a Deployment method](/choosing-a-deployment-method.md)
