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Walkthrough does not play correctly
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Walkthrough does not play correctly

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Walkthroughs are displayed based on the visibility rules that are set up when creating the walkthrough. If a walkthrough is failing at a step, it usually means that the conditions required to show the next step are not being met.

Causes:

There may be many reasons that are responsible for your walkthrough not working. Listed below are a few reasons and some solutions that you could try to fix the issue.

  • Something may have changed in the underlying application and Whatfix is unable to find the element that was selected when the walkthrough was created.
  • The step conditions for the walkthrough may be incorrect or the step may be an optional one and the conditions don't match.
    • For example, one of the reasons may be the step condition that is being evaluated while the page is still loading. So if you are using the on-click of element visibility rule, try switching to the on page refresh rule.
      For more information, see Step completion rules.
  • The walkthrough may have been captured in an UAT environment, but is being played in Production
  • The application may be taking time to load and the visibility rule that determines the display of content may not be the most optimal condition. For example, the rule may be set to be triggered for the on click of the selected element, but since the page has not refreshed, the element that is supposed to trigger the next step is not yet displayed and thus the step does not display.
    • Element IDs are different in UAT and Production and the account has been configured to trust IDs
  • There may be a conflict in the configuration and the walkthrough may not be displaying on the intended page.

Solutions:

Navigate to the step that is not working and try reselecting the step.

  • Verify if the the step conditions for the step that is failing is correctly configured.
  • Ensure that the walkthrough was created in an environment that is identical to what you have in production. The element attributes in production are often found to be different from UAT.
    • If the walkthrough was created in a UAT environment, and the account has been configured to trust IDs, ensure that the IDs are the same in both environments.
  • If you are facing issues with IS enabled accounts, contact your CSM to troubleshoot further
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