- 11 Aug 2025
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User Attribute is showing as Corrupted in Trend Insights
- Updated On 11 Aug 2025
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Issue
The User Attribute, such as role or team, you want to add as a User filter in Trend Insights has a Corrupted chip next to it.
Probable Cause
A User Attribute becomes Corrupted when there are 100 values and above captured over a time period for the specific Attribute. For example, consider that you’re capturing a user’s role as a User Attribute. It is safe to assume that user roles don’t change very often. However, if the User Attribute is incorrectly configured, the Attribute used to capture role might start capturing more values, which affects the analytics data.
Hence, to ensure that incorrectly configured User Attributes don’t impact data, Whatfix regularly checks the values captured for each User Attribute. If the Attribute contains 100 values and above (not unique), Whatfix marks them as Corrupted.
Note:
User Attributes can be added as User filters in Trend Insight, Funnel Insight, User Journey, Dashboards, and Cohorts. If an Attribute’s value exceeds 100, a Corrupted chip appears next to the Attribute across all components.
Suggested Solution
Whatfix enables you to select the corrupted User Attribute. However, if you’re able to see the Corrupted chip next to your User Attribute, contact support@whatfix.com to correct the Attribute.