Top
Task List does not appear in the Preview Mode
  • 11 Nov 2024
  • 2 Minutes To Read
  • Dark
    Light
  • PDF

Task List does not appear in the Preview Mode

  • Dark
    Light
  • PDF

Article summary

Issue

You have created a Task List but the Task List is not appearing on your application when you preview it.

Probable Causes

  • Preview Mode is not enabled.
  • The Task List segment is not pushed to the Ready stage.
  • Incorrect Visibility Rule conditions have been configured.
your title goes here

Incorrect Visibility Rules that are commonly used:

  • Adding URL Equals instead of Contains: When you use equals as a condition instead of contains, the Task List is displayed only when the URL is exactly the same as entered. If the URL is slightly altered, the Task List is not displayed on the page.
    clm_visibility rules_contains

  • Selecting the rule as URL Path and adding the domain name, which is the value for the URL Hostname rule. When a domain name is added instead of the URL Path, the rule is not evaluated and the Task List is not displayed.
    clm_visibility rules_url path

For more information, see Visibility and Display Rule conditions.

  • When you are adding more than one Visibility rules, then ensure that the right operator is used.

  • Use And operator if the Task List needs to be shown only when all the conditions are evaluated as true.

  • Use Or operator if the Task List needs to be shown when any one of the conditions is evaluated as true.

  • The Preview extension is not installed.
your title goes here

If your account relies on Advanced Customization (AC) code for certain features, those specific capabilities aren't visible in Preview Mode using Whatfix Studio. For example, if the Styles section, Window Variables, or Role Tags are configured using AC code, Preview Mode does not display these changes. The Preview extension is required to view AC code changes or any content affected by them. For more information, see Use Preview extension to test Whatfix Content.

Suggested Solutions

  • Check if the Preview mode is on.
    clm_tl_preview mode

For more information on how to enable the Preview Mode, see How to use preview mode to review content?

Also, after you enable the preview mode, remember to refresh the browser.

your title goes here

If the issue persists, contact support@whatfix.com.


Was this article helpful?

Changing your password will log you out immediately. Use the new password to log back in.
First name must have atleast 2 characters. Numbers and special characters are not allowed.
Last name must have atleast 1 characters. Numbers and special characters are not allowed.
Enter a valid email
Enter a valid password
Your profile has been successfully updated.