PDF content is not showing in QuickRead
- 05 Nov 2024
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PDF content is not showing in QuickRead
- Updated On 05 Nov 2024
- 1 Minute To Read
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Issue
When you search in Self Help, you encounter one of the following scenarios:
- QuickRead does not generate a response, even though relevant content exists in a PDF.
- QuickRead generates a response, but a relevant PDF is not part of the response's Sources.
In both cases, QuickRead either shows no response or provides a response that excludes content from the relevant PDF.
Probable Causes
- QuickRead has not processed your PDFs yet.
- Your PDF visibility is restricted by Role tags.
- Your PDF is part of a repository that is behind authentication.
- The PDF is greater than 4MB in size.
Suggested Solutions
- Disable and re-enable QuickRead from your dashboard for QuickRead to process your PDFs. Use the following steps:
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On the Whatfix Guidance dashboard, click Style.
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Click Self Help.
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Click Smart features.
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In the QuickRead dropdown, disable the QuickRead toggle.
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Click Save.
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In the QuickRead dropdown, enable the QuickRead toggle.
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Click Save.
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After you re-enable QuickRead, use Preview mode in Studio to test it on Self Help. You must do a push to Production for these changes to reflect for your end users.
- Information from PDFs are filtered from QuickRead's responses if you do not satisfy the Role tag requirements to see the PDF. For more information, see Add Page tags and Role tags to your content.
- Add the PDF in a repository that does not require authentication, or as Whatfix content.
- For QuickRead to generate responses based on a PDF content type, the PDF's size must be less than or equal to 4MB.
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If the issue persists, contact support@whatfix.com.
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