Top
Inhalt wird nicht in den Suchergebnissen des Explorers angezeigt
  • 20 Jun 2024
  • 2 Minuten zu lesen
  • Dunkel
    Licht
  • pdf

Inhalt wird nicht in den Suchergebnissen des Explorers angezeigt

  • Dunkel
    Licht
  • pdf

Artikel-Zusammenfassung

Ausgabe

Es gibt keine Inhalte in den Suchergebnissen des Explorers, obwohl es relevante Inhalte auf Ihrem Whatfix Guidance Dashboard gibt.

Ursachen:

Inhalte werden unter den folgenden Umständen möglicherweise nicht in den Suchergebnissen des Explorers angezeigt:

  • Der Inhalt enthält nicht die relevanten Schlüsselwörter, die im Suchausdruck verwendet werden.

  • Die Tags in Ihrem Suchbereich schränken ein, welche Inhalte in den Suchergebnissen angezeigt werden. Wenn Sie Tags im Suchbereich verwenden, werden nur die Inhalte mit den entsprechenden Tags in den Suchergebnissen des Explorers angezeigt.
    RBsearch scope

  • Der Inhalt ist segmentiert, um nicht für bestimmte Benutzer basierend auf ihren Rollen sichtbar zu sein.

Debuggen:
Auf einer Seite geladene Tags identifizieren

Gehen Sie wie folgt vor, um die Debug-Protokolle abzurufen:

  1. Gehen Sie zu der Seite in Ihrer Anwendung, auf der Sie die geladenen Tags abrufen möchten.
    support_site.png

  2. Öffnen Sie den Browser Entwickler Tools.
    support_devtools.png

  3. Gehen Sie zur Registerkarte Konsole.
    debug_console.png

  4. Tippen Sie _wfx_settings.debug_mode=true; and press Enter.
    debug_mode.png

Info:

Hier setzen Sie die Variable _wfx_settings.debug_mode auf den Wert true, wodurch Whatfix angewiesen wird, Debug-Protokolle für Whatfix-Widgets zu erstellen, wenn diese auf einer Seite geladen werden.

  1. Tippen Sie _wfx_refresh(); und drücken Sie Enter.
    wfx_refresh.png
Info:

Mit dem Befehl _wfx_refresh(); werden alle Whatfix-Inhalte und -Widgets, die auf der Seite geladen werden sollen, neu geladen.


Nachdem Sie die Debug-Protokolle erhalten haben, klicken Sie auf IS is enabled : applying on top of base segment, um die Ausgabe zu erweitern.
debug_IS_is_enabled.png

Darin befinden sich Objekte mit den Namen der Tags, die auf der jeweiligen Seite ausgewertet werden.
debug_tag_name.png

Jedes Objekt enthält die folgenden Informationen:

  • Bedingungen: Die Bedingungen, die für das Laden dieses Tags erforderlich sind.
  • Flows: Die Anzahl der Inhalte, denen dieses Tag zugeordnet ist.
  • Name: Der Name des Tags.
  • Typ: Der Typ des Tags, d. h. Page, Role oder Andere Tag.
    debug_evaluated_tag.png

  • Die globale Suche ist für Smart Context-aktivierte Konten deaktiviert

Lösungen:

  • Vergewissern Sie sich, dass der Inhalt im Segment Self Help hinzugefügt wird.

  • Fügen Sie relevante Schlüsselwörter in den Inhalt ein, damit er in den Suchergebnissen auftaucht. Weitere Informationen finden Sie unter Benutzer bei der Suche nach Inhalten mit Suchbegriffen helfen.

  • Überprüfen Sie die Tags, die mit dem Inhalt verbunden sind, der in den Suchergebnissen des Explorers angezeigt werden soll.

  • Überprüfen Sie, ob User Roles zum Segmentieren von Inhalten verwendet werden. Stellen Sie in diesem Fall sicher, dass die Inhalte dem spezifischen Self Help-Segment hinzugefügt werden.

  • Stellen Sie sicher, dass der globale Page Tag an statischem Inhalt angehängt wird, damit er in der gesamten Anwendung sichtbar ist. Weitere Informationen finden Sie unter Page Tags und Role Tags zu Ihrem Inhalt hinzufügen.

  • Konfigurieren Sie die Einstellungen, um die globale Suche zu ermöglichen, wenn Sie Smart Context aktiviert haben. Weitere Informationen finden Sie unter Smart Context.

your title goes here

Wenn das Problem weiterhin besteht, wenden Sie sich an support@whatfix.com.


War dieser Artikel hilfreich?

Changing your password will log you out immediately. Use the new password to log back in.
First name must have atleast 2 characters. Numbers and special characters are not allowed.
Last name must have atleast 1 characters. Numbers and special characters are not allowed.
Enter a valid email
Enter a valid password
Your profile has been successfully updated.