SharePoint Excel integrations fail regularly

Prev Next

Issue

Whatfix’s App Integration fails to fetch data from an Excel file stored on Microsoft SharePoint.

Probable Cause

Microsoft issues access tokens for a limited duration. Access tokens are used to authorize access to services, such as SharePoint or OneDrive. When the token expires, the related integrations on the Whatfix Guidance dashboard using that connection fail.

For more information, see Access tokens for Microsoft Services.

Suggested Solution

Access tokens might expire based on policies set by Microsoft. When you add a new connection on the Whatfix Guidance dashboard, a new authentication token is generated, and restores access.

Use the following steps to add a new connection for the integration and run the integration:

  1. On the Whatfix Guidance dashboard, click Settings.
    ia_left_nav_settings

  2. Click App integrations.
    ia_left%20nav_app%20integrations

  1. Go to the required integration and then click the more icon.

  1. Click Edit.

  1. Click Add New Connection, and then authorize Whatfix to access your Excel file stored in your SharePoint directory.

  1. Click Save.

  1. Click the more icon once again.

  1. Click Run now.

Verify if the integration runs correctly.

Note:

If the issue persists, contact support@whatfix.com.