Unable to capture user ID in public Survey

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Issue

User IDs are not captured for Public Surveys.

Probable Cause

Public Surveys always open in a new browser tab. They are not tied to the end user's profile in the application, so they cannot capture the user ID used for identification. This is the intended behavior of Public Surveys. Instead of a user ID, the Survey captures a generic identifier (such as a cookie ID) to track responses anonymously.

Suggested Solution

If you need to tie a Survey to a specific user ID, create and publish a Survey as a widget or use it in a Launcher. These methods ensure that the Survey opens directly on the application page, enabling Whatfix to track user IDs.

Note:

If the issue persists, contact support@whatfix.com.

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