- 23 Jul 2025
- 2 Minutes To Read
- Print
- DarkLight
- PDF
Survey is not visible in production
- Updated On 23 Jul 2025
- 2 Minutes To Read
- Print
- DarkLight
- PDF
Issues
Survey is not visible in production.
Survey is visible to one user, but not another.
Probable Causes
Survey is not pushed to production.
Once you exhaust the occurrence count of the Survey, you might not see it anymore. For instance, if the Survey occurrence limit is set to 1 and you have viewed it already once, then the Survey doesn’t appear any more.
If you have set a specific date and time for the Survey to appear, it might expire and/or not appear outside those specified dates and times.
The Survey might not be visible if you have attached certain Role tags and your users have different roles.
If your users are not part of the list during the Google sheet integration process, they might not see the Survey in the application.
If you're using the Whatfix Browser Extension for content delivery
The Whatfix browser extension is not updated.
Suggested Solutions
Check if the Survey is pushed from the Ready stage to the Production stage. For more information, see Push Whatfix content and widgets to Production.
Adjust the occurrence count of the Survey so that it appears for a set number of times.
Check the Visibility Rules for When the Survey must appear, that is, date and time. For more information, see Visibility and Display Rule Conditions.
Note:
Some of the Incorrect Visibility Rules that are commonly used are as follows:
Adding URL Equals instead of Contains: When you use equals as a condition instead of contains, the Survey is displayed only when the URL is exactly the same as entered. If the URL changes, the Survey is not displayed on the page.
Selecting the rule as URL Path and adding the domain name, which is the value for the URL Hostname rule: When a domain name is added instead of a URL Path, the rule is not evaluated, and the Survey is not displayed. For example, in the following URL adding ap17.lightning.force.com as the URL path instead of /lightning (URL: https://ap17.lightning.force.com/lightning/#lead/list?filterName=Recent) might be the cause for the Survey not appearing on the application.
For more information, see Visibility Rules Best Practices.
When you add more than one Visibility Rule, then ensure that the right operator is used.
a. Use the And operator to show the Survey only if all the conditions are evaluated as true.
b. Use the Or operator to show the Survey if any one of the conditions is evaluated as true.
If you want specific users to see the Survey, ensure they are added to the Google Sheet used for integration. For more information, see Google Sheet Integration with User Attribute.
Ensure you add the respective Role tags for users with specific roles to view the Survey.
If you're using the Whatfix Browser Extension for content delivery
If you use an extension-based deployment, you might have to wait up to 30 minutes before the content appears for your end users. This time might vary based on the extension's hosting location, such as the Chrome Web Store, Microsoft Store, or any other store. To reduce this delay, Whatfix recommends that you host your extension on the Whatfix Store. Updates typically reflect within a few minutes. For more information, see Whatfix Store: Our recommended choice to host Whatfix extensions.
Note:
Always test Surveys using the Whatfix Preview mode before pushing them to production. For more information, see Preview a Survey.
Consider you want to roll out a Survey, but the Survey isn’t visible while using Preview mode. With the Whatfix Diagnostics Panel, identify issues with Surveys, understand why they aren’t working, and learn to resolve those issues.
If the issue persists, contact support@whatfix.com.