- 17 Jun 2025
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Content not appearing in Explorer's search results
- Aktualisiert am 17 Jun 2025
- 2 Minuten zu lesen
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Issue
There is no content in Explorer's search results, despite there being relevant content on your Whatfix Guidance dashboard.
Probable Causes
Content may not appear in Explorer's search results under the following circumstances:
- The content doesn't have the relevant keywords that are being used in the search phrase.
- The tags in your search scope are restricting which content shows up in the search results. If you use tags in your search scope, only content with the appropriate tags show in Explorer's search results.
- The content is segmented to not appear to certain users based on their roles.
Ensure that your content contains a tag or combination of tags that are present on the page. To check which tags are loading on a particular page, use Whatfix's debugging commands in your browser's Developer Tools. For more information, click the following accordion:
Use the following steps to get the debug logs:
Go to the page in your application where you want to get the loaded Tags.
Open your browser's Developer Tools.
Go to the Console tab.
Type _wfx_settings.debug_mode=true; and press Enter.
Here, you are setting the _wfx_settings.debug_mode variable to a true value, which instructs Whatfix to provide debug logs for Whatfix widgets whenever they load on a page.
- Type _wfx_refresh(); and press Enter.
The _wfx_refresh(); command reloads all Whatfix content and widgets that are supposed to load on the page.
After getting the debug logs, click IS is enabled : applying on top of base segment to expand its output.
Inside, there are objects containing the names of the Tags evaluated on that particular page.
Each object contains the following information:
- conditions: The conditions required for that Tag to load.
- flows: The count of content this Tag is attached to.
- name: The name of the Tag.
- type: The type of the Tag, that is, Page, Role, or Other Tag.
Suggested Solutions
Ensure that the content is added in the Self Help segment.
Include relevant keywords in the content so that it shows up in the search results. For more information, see Help users find content using search keywords.
Check the tags that are attached to the content that must appear in Explorer's search results. For more information, see Search Scope of a Self Help segment.
Check whether user roles are used to segment content. If so, ensure that the content is added to the specific Self Help segment.
Note:If the issue persists, contact support@whatfix.com.