- 16 Jun 2025
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Content not showing in Explorer
- Aktualisiert am 16 Jun 2025
- 1 Minute zum Lesen
- Drucken
- DunkelLicht
- pdf
Issue
- You have added content to your Improved Self Help segment, but it does not display in Explorer when you try to access it on the application.
- Improved Self Help content is not displayed in the Development instance.
Probable Causes
- Content such as Flows, Videos, and Articles, may not show up in Explorer in the Production instance when the content,
- Is not a part of any Self Help segment.
- Does not have proper tags attached to it.
- Is segmented to not appear to certain users based on their user roles.
You must tag your content with a tag or combination of tags that are present on the page. To check which tags are loading on a particular page, you can use Whatfix's debugging commands in your browser's Developer Tools. For more information, click the following accordion:
Use the following steps to get the debug logs:
Go to the page in your application where you want to get the loaded Tags.
Open your browser's Developer Tools.
Go to the Console tab.
Type _wfx_settings.debug_mode=true; and press Enter.
Here, you are setting the _wfx_settings.debug_mode variable to a true value, which instructs Whatfix to provide debug logs for Whatfix widgets whenever they load on a page.
- Type _wfx_refresh(); and press Enter.
The _wfx_refresh(); command reloads all Whatfix content and widgets that are supposed to load on the page.
After getting the debug logs, click IS is enabled : applying on top of base segment to expand its output.
Inside, there are objects containing the names of the Tags evaluated on that particular page.
Each object contains the following information:
- conditions: The conditions required for that Tag to load.
- flows: The count of content this Tag is attached to.
- name: The name of the Tag.
- type: The type of the Tag, that is, Page, Role, or Other Tag.
Suggested Solutions
- Ensure that the content is part of a segment. Content is displayed in Explorer only if it is part of a Self Help segment.
- If you are using a role tag, ensure that all your content has at least one role tag.
- Check if the content is appropriately tagged.
If the issue persists, contact support@whatfix.com.