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Role Tags do not work
  • 05 Nov 2024
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Role Tags do not work

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Article summary

Issue

Content with Role Tags attached does not appear in the Self Help widget.

Probable Cause

The Role Tag Visibility rule configured while creating the Self Help widget overrides any Role Tags attached to the content added in the Self Help widget.

For example, if you have Flows with Account Manager and Content Manager tags attached and add them to a Self Help widget with a Editor Role Tag configured in the Visibility Rule, the Self Help widget along with all the Flows are visible only to the Editor role, irrespective of the other Role Tags attached to the content.

Suggested Solutions

  • Ensure that you add the relevant user roles' tags to the widget segment. In the given example, add the Account Manager and Content Manager tags to the widget segment.

  • If you want to show content based on different user roles, create dedicated segments for each role in Self Help and add relevant content to each segment. To know more, see Displaying content based on User Roles.

  • Once these segments are created, Whatfix needs user information from your application to identify your users and associate their roles to display relevant content. This can be done using Window Variables, URL, or Other Elements on a page Visibility Rule. The necessary values for each role have to be added to the respective Widget segments' Visibility Rule.

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If the issue persists, contact support@whatfix.com.


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