- 04 Jul 2025
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Self Help Flows appear on unintended pages
- Updated On 04 Jul 2025
- 2 Minutes To Read
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Issue
Flows in the Self Help widget might appear on pages where they are not intended to appear. When users launch these Flows, they might start on those pages and fail to run. The reason for the failure is that the required UI elements or steps necessary for the Flow to start are not present on the current page. As a result, users might have a disrupted experience.
For example:
Consider that you have configured a Self Help widget to appear on multiple pages by adding several Page Tags in its Visibility Rules. Some Flows in the widget are only relevant to specific pages. However, these flows appear on all tagged pages.
Why does this happen?
When Page Tags are used in the widget’s Visibility Rules, they control the visibility of the entire widget, and not the individual Flows inside it. Once the widget becomes visible on a page (because that page matches the rule), it shows all the Flows included in the widget, regardless of whether those Flows are relevant to the current page. If a user launches a Flow that is not relevant to the current page, it might start but fail to run because the necessary steps or UI elements are not present.
Probable Causes
The issue occurs because of how Visibility Rules and Page Tag filtering are configured to work in the Self Help widget:
Note:
If you see the following UI, you have the Advanced Visibility Rules enabled for the account. For more information, see Understand Advanced Visibility Rules.
When you add a Page Tag condition to the Visibility Rules section of a Self Help widget, the default Smart Context-based content filtering is overridden. This means that:
Whatfix applies filtering only at the widget level and not at the individual Flow level. For more information on Smart Context, see Smart Context.
If the Page Tag condition for the Self Help evaluates to true, the widget appears and displays all included Flows, even if the individual Flows' page tags do not match the current page.
As a result, Flows that are not relevant to the current page might appear. When users launch these Flows from the Self Help widget, the Flow might start but fail to run because the required steps or elements do not exist on the current page.
Suggested Solutions
Review whether widget-level Visibility Rules are required. If they are not required, remove these rules to enable the default Smart Context-based content filtering. This ensures each Flow appears only on the pages it’s relevant to.
If your use case requires widget-level Visibility Rules, such as adding Page Tags to a Self Help widget, ensure the widget includes Flows that work on all the pages where the widget appears.
For example, if the Self Help widget appears on both the User Profile and Settings pages, only include Flows that work on both pages. Avoid adding Flows that work on just one page. If a Flow is meant for the User Profile page but shows up on the Settings page, it might not work because the required UI elements are missing.
Note:
If the issue persists, contact support@whatfix.com.