Issue
Flow has failed because 'Step is not created on the currently opened page.'
Probable Causes
Following are some potential cases where a Flow might fail because 'Step is not created on the currently opened page.'
- The element on which the step is created does not exist on the page where the Flow is running.
- The application UI over which the step was created may not be the same as the one over which the Flow is played.
- For a Flow created across multiple pages, it may lead to a Flow failure if the necessary conditions to redirect to the URL are not met and the page on which the Flow is supposed to continue doesn't load.
Suggested Solutions
- Check the Flow to see if the previous steps are navigating to the desired page on which the failed step should appear.
- In case of a discrepancy, re-select the element or verify the CSS selectors on which the step is failing. For more information, see Reselect Elements to manage UI changes