- 04 Nov 2024
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Launcher does not appear on the application
- Updated On 04 Nov 2024
- 1 Minute To Read
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Issue
You have configured Launchers, but they are not appearing on your application.
Probable Causes
- The Launcher segment is not pushed to Production.
- Launchers may not appear if you've pushed only the content and not the widget.
- Incorrect Visibility Rule conditions have been configured.
Incorrect Visibility Rules that are commonly used:
- Adding URL Equals instead of Contains: When you use equals as a condition instead of contains, the Launcher is displayed only when the page's URL exactly matches the provided URL. Even if the page's URL is slightly different, the Launcher is not displayed on the page.
- Selecting the rule as URL Path and adding the domain name, which is the value for the URL Hostname rule: When a domain name is added instead of the URL Path, the rule is not evaluated and the Launcher is not displayed.
For more information, see Visibility and Display Rule conditions.
- When you are adding more than one Visibility Rule, ensure that the right operator is used.
a. Use the And operator when the Launcher needs to be shown only if all the conditions are evaluated as true.
b. Use the Or operator when the Launcher needs to be shown if any one of the conditions is evaluated as true.
Suggested Solutions
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Push your Launcher segment from the Ready stage to the Production stage to make it live on the application.
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Ensure that you push the widget first from the Widgets section, as this guarantees that the segment and its associated content are simultaneously pushed to Production. For more information on pushing a widget to Production, see Push Whatfix content and widgets to Production.
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Use the correct Visibility Rule conditions to show your Launchers. Also, add the right conditions AND/OR if you are adding more than one Visibility Rule. OR means that any of the conditions if true will validate the rule. AND means both the conditions need to be true for the content to display.
If the issue persists, contact support@whatfix.com.