Top
Role Tags do not work
  • 19 Jan 2024
  • 1 Minute To Read
  • Dark
    Light
  • PDF

Role Tags do not work

  • Dark
    Light
  • PDF

Article Summary

Issue

Content with Role Tags attached does not appear in the Self Help widget.

Cause

The Role Tag visibility rule configured while creating the Self Help overrides any Role Tags attached to the content added in the widgets.

For example, if you have Flows with an Account Manager and a Content Manager tag attached and add them in a Self Help widget with a Studio Role Tag configured in the Visibility Rule, then the Self Help widget along with all the Flows is visible only to the editor role irrespective of the other Role Tags attached to the content.

Solution

  • Make sure to add the relevant user roles' tags to the widget segment. In the given example, add the Account Manager and Content Manager tags to the widget segment.

  • If you want to show content based on different user roles then create dedicated segments for each role in Self Help and add relevant content to each segment. To know more, see Displaying content based on User Roles.

  • Once these segments are created, Whatfix needs user information from your application to identify your users and associate their roles to display relevant content. This can be done using Window Variables, URL, or Other Elements on a page Visibility Rule. The necessary values for each role have to be added to the respective Widget segments' Visibility Rule.

your title goes here

If the issue persists, contact support@whatfix.com.


Was this article helpful?

Changing your password will log you out immediately. Use the new password to log back in.
First name must have atleast 2 characters. Numbers and special characters are not allowed.
Last name must have atleast 1 characters. Numbers and special characters are not allowed.
Enter a valid email
Enter a valid password
Your profile has been successfully updated.