- 05 Oct 2025
- 1 Minute To Read
- Print
- DarkLight
- PDF
Task List does not display
- Updated On 05 Oct 2025
- 1 Minute To Read
- Print
- DarkLight
- PDF
Issue
The Task List does not appear on the application.
Probable Causes
The segment is not live on the application.
The tasks in the Task List are completed.
The Task List segment does not contain any content.
Visibility Rules aren’t set up correctly or have expired. For more information, see Visibility Rules.
The User Action that triggers the Task List is not in the Production stage.
An incorrect Window Variable is used. For more information, see Window Variables as Visibility Rules.
Suggested Solutions
After you create a segment, to make it visible to end users, move it from the Ready stage to the Production stage. To understand how to publish a segment, see Push Whatfix content and widgets to Production.
Note:
You cannot push an empty Task List segment to the Production stage in the Enhanced Publishing Experience. Include at least one content piece in the segment before moving it to production.
A Task List stops displaying when a user completes all the tasks. This is the expected behavior.
Check if you have content in the Task List. Whatfix is configured to display the Task List segment only if you have created one content piece that involves element selection. This means that there should be at least one content in it.
Set the correct Visibility Rules for your Task List segment. For more information, see Visibility and Display Rule Conditions.
After you create a User Action, it has to be made live by moving it from the Ready stage to the Production stage. To understand how to publish a User Action, see Push all Whatfix content and widgets to Production.
Ensure you use the correct Window Variable.
Note:
If the issue persists, contact support@whafix.com.