- 02 Jun 2025
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Why do I see untranslated content in Self Help?
- Updated On 02 Jun 2025
- 1 Minute To Read
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Issue
You have translated all the content in Self Help, but you still see some untranslated content, such as the title, description, and other content in Self.
Probable Cause
When you translate Whatfix content, particularly text within the Self Help widget, it's important to understand there are a few key aspects involved:
First, the Whatfix content you have added to the Self Help widget, which includes Flows you have created to guide your end users, Links, and Videos to external resources.
Second, the default text of the Self Help widget interface itself. For example, the title and description of a Self Help widget are classified as Custom Labels and are not translated when you translate Whatfix content.
Additionally, you might have used Folders within the Self Help widget that appear in your Primary language.
Suggested Solutions
To translate the title and description of the Self Help widget, perform the following steps:
On the Whatfix Guidance dashboard, click Settings.
Click Translations.
In the Translations section, select the language.
Click Custom labels.
In the Categories section, click Self Help (New) - Explorer.
To change the title of the Self Help widget, enter the translated text for the Label explorerWidgetTitle in the Input translations field.
To change the description of the Self Help widget, enter the translated text for the Label explorerIntroductionHelperText in the Input translations field.
Click Save.
To translate the folders in the Self Help widget, see Translate Self Help Folder Names.