- 05 Nov 2024
- 1 Minute To Read
-
Print
-
DarkLight
-
PDF
User Attribute is showing as Corrupted in Trend Insights
- Updated On 05 Nov 2024
- 1 Minute To Read
-
Print
-
DarkLight
-
PDF
Issue
The User Attribute, such as role or team, you want to add as a User filter in Trend Insights has a chip next to it that says Corrupted.
Probable Cause
A User Attribute becomes Corrupted when there are 100 values and above captured over a period of time for the particular Attribute. For example, consider that you’re capturing the user’s role as a User Attribute. It is safe to assume that user roles don’t change very often. However, if the User Attribute is incorrectly configured, the Attribute, that is the role, for a particular user might start capturing more values, which affects the analytics data.
Hence, to ensure that incorrectly configured User Attributes don’t impact data, Whatfix regularly checks the values captured for each User Attribute. If the Attribute contains 100 values and above (not unique), Whatfix marks them as Corrupted.
Your title goes here
User Attributes can be added as User filters in Trend Insight, Funnel Insight, User Journey, Dashboards, and Cohorts. If an Attribute’s values exceed 100, the Corrupted chip appears next to the Attribute across all components.
Suggested Solution
Whatfix still enables you to select the corrupted User Attribute. However, if you’re able to see the Corrupted chip next to your User Attribute, contact support@whatfix.com to correct the Attribute.