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Beacon does not appear correctly
  • 24 Sep 2025
  • 2 Minutes To Read
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Beacon does not appear correctly

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    Light
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Article summary

Issues

  • Beacon does not appear on the page after you have pushed it to Production.
  • Beacon is not appearing in the desired location on the page.
  • Beacon is hopping, that is, switching from one element to another.
  • Beacon is not appearing in your application.

Probable Causes

  • Beacon might not appear correctly if the wrong segment is present in the Production stage.
  • Beacon might not appear if you've pushed only the content and not the associated widget.
  • Beacon might not show up at the desired location if the wrong element is selected.
  • The content does not contain the required Role tags.
  • There might be multiple similar elements, making it difficult for the Beacon to accurately latch onto the intended element.

If you're using the Whatfix Browser Extension for content delivery

  • The version number of the updated extension on the Whatfix dashboard does not match the version of the Whatfix extension in your browser's extension page.

If you're using the Whatfix Browser Extension for content delivery and the Preview extension to test content

  • There might be a conflict between the browser extension and the Preview extension after the Beacon is pushed to Production. The browser extension is enabled and the Preview extension is disabled.

Suggested Solutions

  • Ensure that the correct Beacon segment you want to display is in the Production stage.
    clm_db_production

  • Ensure that you push the widget first from the Widgets section, as this guarantees that the segment and its associated content are simultaneously pushed to Production. For more information on pushing a widget to Production, see Push Whatfix content and widgets to Production.

  • Try reselecting the Beacon element again. For more information, see Reselect Elements to manage UI changes.

  • Check if you have multiple Beacon segments for a single page active in the Production stage. Whatfix permits only one Beacon segment to be displayed at a time. If you want to show multiple Beacons, combine the Beacons into a single collection. For more information, see Create Beacons.

Note:

To enable this feature, contact support@whatfix.com.

If you're using Whatfix Browser Extension for content delivery

  • Check the updated extension's version number on the Whatfix dashboard and the Whatfix extension in the extension page. They need to be same so that end users can see the latest Whatfix content updates.
    If they are different, try updating the extension again and wait for some time for the extension versions to be in sync. For more information, see How is the browser extension updated?.

If you're using Whatfix Browser Extension for content delivery and Preview extension to test content

  • If there's a conflict between the browser extension and the Preview extension, enable and disable the Preview extension. Refresh the application page and check if you're able to view the Beacon.
Note:

If the issue persists, contact support@whatfix.com.


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