- 25 Jun 2025
- 1 Minute To Read
- Print
- DarkLight
- PDF
Unable to modify CSS for default templates on Studio
- Updated On 25 Jun 2025
- 1 Minute To Read
- Print
- DarkLight
- PDF
Issue
When you try to modify a tooltip template for Flows, Smart-tips, or Beacons using the CSS customization feature on Whatfix Studio, you see the following message:
Probable Cause
The selected tooltip is the default template of the tooltip, for either Flows, Smart-tips, or Beacons.
Suggested Solutions
Only custom tooltip templates created on the Dashboard are editable on Studio.
You must first create a CSS customized template at a Dashboard level, and then select the template at the Studio level. For more information on how to create CSS customized tooltip templates on Dashboard, see CSS customization of tooltips for Flows, Smart-tips, and Beacons. Once the CSS customized tooltip is selected on Studio, it’s possible to customize it further through CSS.
How to customize a tooltip template using CSS on Whatfix Studio?
Once you have created the required tooltips using CSS customization on Whatfix Dashboard, all the custom tooltips start appearing on Studio. Here’s how to view them and make further changes using CSS.
Click Change to select a custom template on Studio.
Once you select the custom template, click CSS to access the code view.
Make further modifications to the template using the CSS code view.
Info:
The changes made at the step level do not reflect on the Dashboard (global level) and therefore remain specific and unique to the step that you edit on Studio.
Note:
CSS customization for tooltips is a Beta feature. Contact support@whatfix.com to enable it.
The CSS code view cannot be deleted.
Before you customize a tooltip, as a best practice, create a backup copy of the code to prevent its unexpected loss.
For Content and Widgets that are already in the published stage, ensure you perform Push to Production for the CSS changes to reflect.
Whatfix enables Account Managers and Content Managers to create CSS customized tooltips. For more information on user roles, see Whatfix user roles.
If the above issue persists, please contact support@whatfix.com.