Self Help does not display

Prev Next

Issue

The Self Help tab does not display on the application.

Probable Causes

Self Help may not display for one or more of the following reasons:

  • The segment is not live on the application.
  • The Visibility Rules aren't set correctly or have expired.
  • There's no content inside the Self Help segment.

Suggested Solutions

  • After a segment is created, it has to be explicitly made live by moving it from the Ready stage to the Production stage.
your title goes here

For more information on pushing widgets to Production, see Push Whatfix content and widgets to Production.

  • Check if you have content in Self Help.
    Whatfix is configured to display the Self Help tab only if you have created at least one content unit that involves element selection. This means there should be at least one Flow in it.

  • Set correct Visibility Rules. For more information, see Visibility and Display Rule Conditions.

your title goes here

Incorrect Visibility Rules that are commonly used:

  • When you are adding more than one Visibility Rule, then ensure that the right operator is used.

  • Use And operator when the Self Help needs to be shown only when all the conditions are evaluated.

  • Use Or when the Self Help should be shown when any one of the rules is true.

your title goes here

If the issue persists, contact support@whatfix.com.

Privacy Policy | Whatfix Glossary | Whatfix Platform Status
Copyright © 2024 WHATFIX TM. All rights reserved.