- 05 Nov 2024
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Microsoft Teams is flickering when Whatfix is running
- Updated On 05 Nov 2024
- 1 Minute To Read
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Issue
When you try to open Microsoft Teams with the Whatfix Desktop Studio or Player, the screen starts flickering.
Probable Cause
Whatfix Desktop uses Microsoft Accessibility to identify User Interface (UI) elements on Microsoft Teams. Accessibility isn't enabled by default in the Microsoft Teams application and hence Whatfix programatically enables accessibility by slightly resizing the Microsoft Windows. Microsoft Accessibility is enabled whenever Microsoft Teams is initiated or becomes the active window and comes into focus. When Microsoft Teams window is resized it appears to flicker with or without Whatfix. The flickering is more prominent when the machine (CPU/Memory) is near full capacity.
Whatfix enables accessibility for the following scenarios,
All the following scenarios are applicable only when Microsoft Teams window is in maximized mode.
- When launching the Whatfix Player for the first time on top of Microsoft Teams window
- When Microsoft Teams is relaunched after it is closed
- When your end-user clicks on Microsoft Teams notifications while the application is minimized but still running in the background
- When your end-user minimizes and maximizes Microsoft Teams window including when the end-user is interacting with Whatfix content such as a Flow.
- When your end-user changes the display and/or screen resolution settings
- When changing the Primary Monitor to the Secondary Monitor or vice versa (in case of Dual Monitor)
- When the machine is on sleep/hibernate/system lock/unlock modes and when the end-user restarts the machine.
- When the Network status of the machine is changed. For example, when the machine is switched to a LAN connection from Wifi or when Wifi is turned off/on etc.
Suggested Solution
We observe that the flickering is usually due to hardware and software related issue. Microsoft Teams doesn't flicker if the end user's machine has the latest OS/software updates and has sufficient CPU/memory.
If the issue persists, contact support@whatfix.com