- 30 Oct 2024
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Content does not show in Self Help's search results
- Updated On 30 Oct 2024
- 1 Minute To Read
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Print
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Issue
Content does not appear inside Self Help when searching for it.
Probable Causes
Content may not appear in the Self Help widget under the following circumstances,
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The content has not been added in the Self Help segment. If you want content to appear in search, you need to first add them in the default segment of Self Help. For example, when you are using a Tag in search scope to make them appear inside Self Help when searching, you need to first add the same Tag to the default segment of Self Help.
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The content doesn't have the relevant keywords that are being used in the search phrase.
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The Tags attached are restricting the search scope, thus preventing content from showing up when searching in Self Help. If you put Tags in search scope, then only the content with the same Tag shows during search in Self Help.
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The content is segmented to not appear to certain users based on their roles.
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The static content does not have the necessary Tags.
- The Global search is disabled for Smart Context-enabled accounts
Suggested Solutions
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Ensure that the content is added in the Self Help segment.
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Include relevant keywords in the content so that it shows up in the search results.
For more information, see Help Users Find Content in Self Help using Keywords -
Check the Tags that are attached to the content that ought to appear in Self Help. There could be a conflict where you may need to remove or update a Tag to ensure the content shows up again.
For more information, see Add Page Tags and Role Tags to content -
Check whether user roles are used to segment content. If so, make sure the contents are added to the specific Self Help segment.
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Ensure that the global page Tag is attached to static content so that it is visible all through the application.
For more information, see Add Global Tag to the content -
Configure the settings to allow global search if you've enabled Smart Context.
For more information, see Smart Context
If the issue persists, contact support@whatfix.com.