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Smart Tips segment not appearing in your application
  • 23 Nov 2023
  • 3 Minutes To Read
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Smart Tips segment not appearing in your application

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Article Summary

Issue

You have configured Smart Tip segments, but they are not appearing in your application.

Causes

  • The Smart Tip segment is not pushed to Production.
  • Smart Tips may not appear if you've pushed only the content and not the widget.
  • Two or more Smart Tip segments are present on the same page.
  • Incorrect Visibility Rule conditions have been configured.
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Incorrect Visibility Rules that are commonly used:

  • Adding URL Equals instead of Contains: When you use equals as a condition instead of contains, the Smart Tip is displayed only when the page's URL exactly matches the provided URL. Even if the page's URL is slightly different, the Smart Tip is not displayed on the page.
    clm_visibility rules_contains
  • Selecting the rule as URL Path and adding the domain name, which is the value for the URL Hostname rule: When a domain name is added instead of the URL Path, the rule is not evaluated and the Smart Tip is not displayed.
    clm_visibility rules_url path

For more information, see Visibility and Display Rule conditions.

  • When you are adding more than one Visibility Rule, ensure that the right operator is used.
    a. Use the And operator when the Smart Tip needs to be shown only if all the conditions are evaluated as true.
    b. Use the Or operator when the Smart Tip needs to be shown if any one of the conditions is evaluated as true.
  • Another Smart Tip segment that is configured to appear on the same page is taking precedence.
  • An iFrame-based CSS Selector, for example, a CSS Selector for an embedded video player, is set in the Smart Tip segment's Visibility Rule.
  • Clicking Push to production automatically updates the extension and pushes the newly created Smart Tip to the cloud server. The success email you receive denotes the completion of this process. But it may take a little longer before it can be seen by your end user's extension.

Solutions

  • Push your Smart Tip segment from the Ready stage to the Production stage to make it live on the application.

  • Ensure that you push the widget first from the Widgets section, as this guarantees that the segment and its associated content are simultaneously pushed to Production. For more information on pushing a widget to Production, see Push Whatfix content and widgets to Production.

  • By default, Whatfix evaluates only one Smart Tips collection per page at any given time. If you want to show two or more Smart Tips on the same page, add them to the existing collection.
    If you've created a Smart Tip on a global element and want it to appear on every page, you have to include the Smart Tip in all the respective collections. This is because only one collection is evaluated per page.

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Whatfix enables you to display multiple Smart Tip segments on the same page. To enable this feature, contact [email protected].

  • If Smart Tips are to be used for multiple pages, separate segments need to be created for each individual page. For more information, see Create Smart Tips.

  • Use the correct Visibility Rule conditions to show your Smart Tips. Also, add the right conditions AND/OR if you are adding more than one Visibility Rule.
    and_or_visibility_rules.png

  • Use the correct Display Rule conditions to display the Smart Tips at the right place. Additionally, you can use CSS Selectors to ensure that the Tips appear on the correct element.

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To ensure that the Smart Tip appears correctly on your page/application, add Display Rules to each individual Smart tip within the collection.
For more information on Display Rule conditions to display your Smart Tip, see Visibility and Display Rules Conditions.

  • iFrame-based CSS Selectors can only be added to the display rules of the Smart Tip. Add the CSS Selector as a Display Rule for each individual Smart Tip. For more information, see Create Smart Tips.

  • Check the updated extension's version number on the Whatfix dashboard and the extension page of your browser. If they are different, try updating the extension again and wait for some time for the extension versions to be in sync. For more information, see Unable to see new content after updating the extension.


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