No events received message for User Actions

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Issue

After creating User Actions, you can see the No events received message on the Whatfix Analytics dashboard.

user_actions_no_events_received.png

Probable Causes

The Last interaction column in the Whatfix Analytics dashboard enables you to see when your User Actions last received engagement. For more information, see Manage User Actions.

When User Actions don’t capture engagement data, you can see the No events received message under the Last interaction column.

Whatfix displays the No events received message in the following scenarios:

  • User Actions are not pushed to Production.

  • User Actions are not configured correctly. You might have configured incorrect Display Rules for the User Action, selected the wrong UI element, or added an incorrect CSS Selector for the User Action.

If you're using the Whatfix Browser Extension for content delivery

Suggested Solutions

Perform the following actions to ensure that your User Actions capture data:

If you're using the Whatfix Browser Extension for content delivery

  • Update the Whatfix Browser Extension to the latest version, then relaunch the browser. Once the extension updates, the User Actions can start capturing data on the live application. Interact with the User Actions to confirm if they capture engagement correctly. After you interact with the User Actions, the No events received message disappears, indicating that User Actions capture engagement data.

Note:

If the issue persists, contact support@whatfix.com.

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