User Actions not available in Insights or Cohorts
- 14 Jan 2025
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User Actions not available in Insights or Cohorts
- Updated On 14 Jan 2025
- 1 Minute To Read
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Issue
The User Actions you created are available on the User Actions page but not listed under Custom events in Insights (Trends, Funnels, and User Journey) or Cohorts.
Probable Causes
- User Actions are available in the User Actions section of the Whatfix Analytics dashboard just after you have finished creating them.
However, User Actions appear in Insights (Trends, Funnels, and User Journey), Cohorts, and Event Groups only after you push them to Production and the action is performed at least once by end users after they're live.
Read the following cause if you're using the Extension mode of deployment:
- After you push User Actions to Production, they might not appear in Insights or Cohorts if the Whatfix extension to view content is not updated to the latest version. If the extension is not updated to the latest version, Whatfix cannot capture the User Action engagement data. For more information on how to check the latest extension version, see Manage Extensions on the Whatfix Dashboard.
Suggested Solutions
- After you create User Actions, verify them and ensure that you push them to Production. Once end users interact with the element on which the User Action is created, the engagement data is reflected in the User Action Analytics insight.
- If you are using the Extension mode of deployment, the extension might not get updated to the latest version if there are any backend issues. If your extension is not updated to the latest version, contact support@whatfix.com.
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If the issue persists, contact support@whatfix.com.
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