Top
Flow does not run correctly
  • 10 Jan 2024
  • 2 Minutes To Read
  • Dark
    Light
  • PDF

Flow does not run correctly

  • Dark
    Light
  • PDF

Article Summary

Issue:

The Flow fails to work correctly when displayed to the end users. The following are some instances of a Flow breaking:

  • The Flow fails to start.
  • The Flow fails to move to the next step even after clicking on the element.
  • The Flow Tooltip appears in an incorrect position.
  • The Flow skips a step.

Causes:

There may be many reasons why your Flow is not working. The following are a few reasons and some solutions that you could try, to fix the issue:

  • Something may have changed in the underlying application, and Whatfix is unable to find the element that was selected when the flow was created.
  • Instead of simple element selection, a CSS Selector may be needed to ensure that the Flow step runs correctly.
  • The step conditions for the Flow may be incorrect or the step may be optional and the conditions don't match.
    • For example, one of the reasons could be that the step condition is being evaluated while the page is still loading. So if you are using the On click of selected element visibility rule, try switching to the On page refresh rule.
your title goes here

For more information, see Step completion rules.

  • The Flow may have been created in a non-production environment, but is being run in the production environment.
  • The application may be taking time to load and the visibility rule that determines the content display may not be optimized. For example, the rule may be set to be triggered by the On click of selected element because the page has not refreshed, the element that is supposed to trigger the next step has not yet been displayed, and thus, the step does not display.
    • Element IDs are different in UAT and Production and the account has been configured to Trust IDs.
  • There may be a conflict in the configuration and the Flow may not be displaying on the intended page.

Solutions:

  • Go to the step that is not working and try reselecting the element. For more information, see Reselect Elements to manage UI changes.
  • Add a CSS Selector if reselection of the element does not work. For more information, see How to find the CSS Selector of an element using Whatfix Studio?
  • Verify if the step conditions for the failed step are correctly configured.
  • Ensure that the Flow was created in an environment identical to what you have in production. The element attributes in production are often different compared to the attributes in UAT.
  • If the Flow was created in a UAT environment, and the account has been configured to trust IDs, ensure that the IDs are the same in both environments.
your title goes here

If the issue persists, contact support@whatfix.com.


Was this article helpful?

Changing your password will log you out immediately. Use the new password to log back in.
First name must have atleast 2 characters. Numbers and special characters are not allowed.
Last name must have atleast 1 characters. Numbers and special characters are not allowed.
Enter a valid email
Enter a valid password
Your profile has been successfully updated.