- 15 Jul 2025
- 1 Minute To Read
- Print
- DarkLight
- PDF
Content does not appear on my application
- Updated On 15 Jul 2025
- 1 Minute To Read
- Print
- DarkLight
- PDF
Issue
Whatfix Content doesn’t load on an application even when you have configured the visibility and display rules correctly.
Probable Cause
Sometimes, if the URL of the application where you want to view the content is not added as a condition in the Whatfix Guidance Dashboard, Whatfix Content doesn’t appear.
If you're using the Whatfix Browser Extension for content delivery
If you use an extension-based deployment, you may have to wait up to 30 minutes before the content appears for your end users. The duration may vary based on the store where the extension is hosted, such as the Chrome Web Store, Microsoft Store, or another store.
Suggested Solution
Ensure you add the instances where you want Whatfix Content to appear in Content deployment section under Settings. For more information, see How to add conditions in Map Stages?.
If you're using the Whatfix Browser Extension for content delivery
If you use an extension-based deployment, you might have to wait up to 30 minutes for the content to appear after pushing to production. The time may vary depending on the store where the extension is hosted. To reduce this delay, Whatfix recommends that you host your extension on the Whatfix Store. Updates typically reflect within a few minutes. For more information, see Whatfix Store: Our recommended choice to host Whatfix extensions.