Incorrect User IDs or cookie values are showing up in Trend Insights
- 02 Aug 2025
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Incorrect User IDs or cookie values are showing up in Trend Insights
- Updated On 02 Aug 2025
- 1 Minute To Read
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Issue
When you add a User ID breakdown in Trend Insights, you're able to see incorrect IDs or cookie values (Anonymized Whatfix IDs) even though User Identification is enabled.
Probable Causes
Incorrect User IDs might appear due to the following reasons:
- The user accesses the application or Whatfix content before logging in. Whatfix can capture user information only after login.
- The user logs in and logs out before Whatfix can identify them using the configured User ID.
- The user accesses a page where the window variable used by Whatfix to capture the User ID is not available.
- User Identification is not configured correctly.
Suggested Solutions
Once a user logs in, actual User IDs are captured if User Identification is enabled. If you're still seeing incorrect User IDs, contact support@whatfix.com to verify the User Identification setup.
Whatfix enables you to filter incorrect User IDs or Anonymous users using the Select user type filter. For more information, see How can I filter unidentified users while analyzing events?
Note:
If the issue persists, contact support@whatfix.com.
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