- 12 Sep 2025
- 1 Minute To Read
- Print
- DarkLight
- PDF
Pop-ups are showing to incorrect Cohort of users
- Updated On 12 Sep 2025
- 1 Minute To Read
- Print
- DarkLight
- PDF
Issue
You've configured a Pop-up to show to a specific group of users in certain countries, such as Canada and the United States of America (USA), using Cohorts as Visibility Rules. However, users in other countries are also seeing the Pop-up.
Probable Cause
The issue occurs due to the time filter set in the Cohort. You might have used the Anytime filter while creating the Cohort.
The Anytime filter includes any user who has logged in from Canada or the USA within the last 30 days, regardless of their current location. A user could be in India today but still see the Pop-up as long as their country was Canada at some point within the last 30 days.
Suggested Solution
To ensure that the Pop-up is displayed only to users currently in the targeted countries, update the Cohort's time filter from Anytime to Most recently. Updating the filter ensures that users who have changed their country within the last 7 or 30 days are still able to view the Pop-up based on their current location.
Use the following steps to create a Cohort with the Most recently filter:
On the Whatfix Analytics dashboard, click Audience.
Click Cohorts.
Click Create cohort.
Click the Give your cohort a name textbox and enter a name for your Cohort.
Click Add rule.
Select Has attribute from the dropdown menu. The rule groups users based on attributes, such as country, city, browser, and OS.
Select the user attribute that you want to track, such as Country.
Select the comparison operator, such as Equals.
Select the value of the attribute (for example, Canada) and then click Apply.
Select Most recently.
Select the required timeframe. For example, during the last 7 or 30 days.
Info:
Here’s how you can create the Cohort.
Click Refresh to view the number of users included in the Cohort.
Click Save.
Note:
Add the Cohort to your Pop-up Visibility Rules. For more information, see Add Cohorts as Visibility Rules.
If the issue persists, contact support@whatfix.com.