- 05 Oct 2025
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Funnel Insights do not capture data correctly
- Updated On 05 Oct 2025
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Issue
You have a four-step process in your application, which you want your users to complete. Whatfix enables you to track the steps using User Actions.
Consider that you’ve created four User Actions (User Action UA1, User Action UA2, User Action UA3, and User Action UA4) for the four-step process.
The following scenario occurs:
User Action | Triggered or not? | Data shown in Funnel |
---|---|---|
UA1 | Triggered | Yes |
UA2 | Not triggered | No |
UA3 | Triggered | No |
UA4 | Triggered | No |
When you check Funnel Insights, it only shows data for the first step and shows no data for the other three steps.
Probable Cause
Based on the scenario, the Funnel Insight only shows data for UA1. The Funnel Insight does not show data for UA2 because it is not triggered, and the subsequent steps (UA3 and UA4) are also not included, although they’re triggered.
Note:
User Action (UA2) might not be triggered due to any of the following reasons:
You haven’t pushed the User Action to Production.
You’ve not selected the correct UI element while creating the User Action.
You’ve added incorrect Display Rules.
This is the expected behavior since Funnels work in a sequential manner. Funnels show data for a step based on the completion of previous steps. Because UA2 is not triggered in the example, the Funnel Insight does not show data for the next steps, UA3 and UA4.
Suggested Solution
Ensure that the User Actions are working correctly before visualizing them using Funnels.
The following actions are recommended to check if User Actions are capturing data correctly:
Check if you have published the User Action.
Verify if the User Action gets triggered using the User Action Verification feature.
Configure the correct Display Rules to help Whatfix identify User Actions better. For example, ensure that you’ve added the correct CSS Selectors for the User Actions.
Check the Last Interaction column in the Whatfix Analytics dashboard to see when was the last time the User Action received engagement.
For more information on the best practices that you need to follow while creating and visualizing User Actions, see User Action Best Practices.
Note:
If the issue persists, contact support@whatfix.com.