Content does not show in Self Help
- 11 Nov 2024
- 2 Minutes To Read
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Content does not show in Self Help
- Updated On 11 Nov 2024
- 2 Minutes To Read
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Issues
- You added content to a Self Help segment, but it does not appear in the segment's default listing.
- Content does not appear in Self Help in a Development instance.
Probable Causes
- Role Tag issues: Consider the following issues may occur if you have at least one Role Tag on your dashboard.
- Your content doesn't have a Role Tag attached to it. If you have at least one Role Tag in your account, all content is expected to have a Role Tag attached to it. Otherwise, it doesn't show to anyone.
- Your role does not match the Role Tags attached to the content. You only see content that is relevant to you according to the content's Role Tag.
- Page Tag issues: The following issues may occur if your content is tagged with Page Tags.
- Your content is tagged with a Page Tag that does not include the page you are viewing the Self Help segment on.
- Smart Context issues: Smart Context, when enabled, automatically tags content created on a particular page with an Auto Tag.
- With Smart Context enabled, all content must have at least one Auto Tag attached to it. Otherwise, it doesn't appear in Self Help.
- Your content may be tagged with an Auto Tag that does not include the page you are viewing the Self Help segment on.
- The application may contain iframes where Whatfix is not being evaluated. This prevents Smart Context configuration and tags from being processed, resulting in content not appearing in Self Help.
- If this is the first time you are setting up Self Help, content may not show up in the Development and Production instances when the conditions given in Map Stages are incorrect.
Suggested Solutions
- If you have Role Tags on your dashboard, ensure all content has a relevant Role Tag attached to it.
- Ensure that your role is suitable to view the content.
- Ensure that Page Tags defined to show content on the required page are attached to your content.
- If your account is enabled with Smart Context, ensure your content has the appropriate Auto Tag.
- For in-app content such as Flows, ensure that the first step is on an element present on the page on which you are viewing the Self Help segment.
- For static content, add the Global-Page tag to the content. This ensures that it shows on all pages when Smart Context is enabled. Further segment it using Page and Role Tags.
- Ensure that the conditions given in Map Stages are correct. For more information, see How to add conditions in Map stages?.
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If the issue persists, contact support@whatfix.com.
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