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Content does not show in Self Help
  • 22 Apr 2025
  • 2 Minutes To Read
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Content does not show in Self Help

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Article summary

Issues

  • You added content to a Self Help segment, but it does not appear in the segment's default listing.
  • Content does not appear in Self Help in a development instance.

Probable Causes

  • Role Tag issues: Consider the following issues that might occur if you have at least one Role Tag on your dashboard.
    • Your content doesn't have a Role Tag attached to it. If you have at least one Role Tag in your account, all content is expected to have a Role Tag attached to it. Otherwise, it doesn't show to anyone.
    • Your role does not match the Role Tags attached to the content. You only see content that is relevant to you based on on its attached Role Tags.
  • Page Tag issues: The following issues might occur if your content is tagged with Page Tags.
    • Your content is tagged with a Page Tag that does not include the page you are viewing the Self Help segment on.
  • Smart Context issues: Smart Context, when enabled, automatically tags content created on a particular page with an Auto Tag.
    • With Smart Context enabled, all content must have at least one Auto Tag attached to it. Otherwise, it doesn't appear in Self Help.
    • Your content might have an Auto Tag that does not include the page you are viewing the Self Help segment on.
    • The application might contain iframes where Whatfix is not being evaluated. It prevents Smart Context configurations and tags from being processed, resulting in content not appearing in Self Help.
  • If it's the first time you are setting up Self Help, content might not show up in the Development and Production instances when the conditions given in Map Stages are incorrect.

Suggested Solutions

  • Ensure all content has a relevant Role Tag if your account uses Role Tags.
  • Ensure your role matches the Role Tags attached to the content.
  • Ensure your content is tagged with the correct Page Tag to make it visible on the required page.
  • If Smart Context is enabled, ensure your content has the correct Auto Tag.
    • For in-app content such as Flows, ensure the first step targets an element present on the page where you are viewing the Self Help segment.
    • For static content such as Links, Videos, Articles, and PDFs, add the Global-Page tag to the content. It ensures that it shows on all pages when Smart Context is enabled. Further segment it using Page and Role Tags.
      Note:

      If your account has multiple Global tags, select the one with the highest value. For example, if the tags in your account are Global-Page, Global-Page_1, and Global-Page_2, content should be tagged with Global-Page_2. For more information on viewing the Global tags available in your account, see How can I view the Global tags created in my account?

  • Ensure that the conditions given in Map Stages are correct. For more information, see How to add conditions in Map stages?.
Note:

If the issue persists, contact support@whatfix.com.


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