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Pop-up not displaying
  • 01 Jun 2023
  • 2 Minutes To Read
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Pop-up not displaying

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Article Summary

Issue:

Pop-up not displaying on the application.

Causes:

A Pop-up may not display for the following reasons:

  • The Visibility Rules aren't set correctly.
  • Pop-up may have expired.
  • Pop-up is not live on the application.
  • Pop-up is restricted to certain user roles.
  • The Pop-up may conflict with another Pop-up with the same Visibility Rules.
  • If the Pop-up is triggered from a User Action, the Visibility Rules of the User Action aren't set correctly.

Solutions:

  • Check if the Pop-up is pushed from the Ready stage to the Production stage. For more information, see Push Whatfix content and widgets to Production.
  • The Pop-up could have expired or been set not to appear on specific dates. Check the Visibility Rules for When the Pop-up must appear, i.e., date and occurrence count.
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Some of the Incorrect Visibility Rules that are commonly used are as follows:

  • Adding URL Equals instead of Contains: When you use equals as a condition instead of contains, the Pop-up is displayed only when the URL is exactly the same as entered. If the URL is slightly altered, the Pop-up is not displayed on the page.
    clm_visibility rules_contains

  • Selecting the rule as URL Path and adding the domain name, which is the value for the URL Hostname rule: When a domain name is added instead of a URL Path, the rule is not evaluated and the Pop-up is not displayed. For example, in the following URL adding ap17.lightning.force.com as URL path instead of /lightning.
    URL: https://ap17.lightning.force.com/lightning/#lead/list?filterName=Recent
    clm_visibility rules_url path

    For more information, see Visibility and Display Rule conditions.

  • When you are adding more than one Visibility Rule, then ensure that the right operator is used.
    a. Use the And operator when the Pop-up needs to be shown only if all the conditions are evaluated as true.
    b. Use the Or operator when the Pop-up needs to be shown if any one of the conditions is evaluated as true.

  • Check whether user roles are used to configure the Pop-up Visibility Rules. If so, ensure that the appropriate user roles are added.
  • Ensure that you don't have two Pop-ups with the same Visibility Rules, Whatfix evaluates only one Pop-up on a page at a time.
Note:

If there are two pop-ups with the same Visibility Rules, then the Pop-up that was created first takes precedence.

  • Check if the Don't show me again option is enabled. Enabling this option gives the end user the option to disable the Pop-up.
  • Check if the Visibility Rules are configured properly for the User Actions. For more information, see User Action as a Visibility Rule.
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  • A widget with User Actions configured as Visibility Rules can be previewed and tested using the Preview mode on Studio.
  • If you have configured multiple Pop-ups with different Visibility Rules to appear on the same page, the Pop-up configured with User Action Completed as the Visibility Rule is always shown first when the end user performs the User Action.
Info

Always test pop-ups using the Whatfix Preview mode before they are visible to your user. For more information on how to Preview a Pop-up, see Preview pop-ups.

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If the issue persists, contact support@whatfix.com.


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